Remove upstreamed patches: 010-menu-fix-the-logic-checking-whether-ESC-key-is-press.patch [1] 011-menu-add-support-to-check-if-menu-needs-to-be-reprin.patch [2] 012-bootmenu-add-reprint-check.patch [3] Remove outdated patches: 455-arm-provide-noncached_set_region-prototype-to-fix-build.patch Some patches have been manually rebased to match the upstream changes. This patch also fixes the dtc warning for reserved-memory dts node. If #address-cells and #size-cells are not same as the root node definitions, the dtc will complain about it. All defconfigs are refreshed by `make "$board"_defconfig` and `make savedefconfig`. [1]ddac69885e
[2]ccdd7948e2
[3]599652cff1
Signed-off-by: Shiji Yang <yangshiji66@qq.com>
12 lines
288 B
Diff
12 lines
288 B
Diff
--- a/Makefile
|
|
+++ b/Makefile
|
|
@@ -1094,7 +1094,7 @@ quiet_cmd_pad_cat = CAT $@
|
|
cmd_pad_cat = $(cmd_objcopy) && $(append) || { rm -f $@; false; }
|
|
|
|
quiet_cmd_lzma = LZMA $@
|
|
-cmd_lzma = lzma -c -z -k -9 $< > $@
|
|
+cmd_lzma = xz --format=lzma -c -z -k -9 $< > $@
|
|
|
|
cfg: u-boot.cfg
|
|
|