Daniel Golle b6415e9fa9 arm-trusted-firmware-tools: update to version 2.12
Upstream changes:
 3789c3c00 build: determine toolchain tools dynamically
 ccbfd01d9 fix(tools): update the fiptool and certtool to fix POSIX build
 7c4e1eea6 build: unify verbosity handling
 10327628c Merge "feat(stm32mp2): add ddr-fw parameter for fiptool" into integration
 a11230ad0 refactor(fiptool): change all occurrences of RSS to RSE
 e494afc05 feat(stm32mp2): add ddr-fw parameter for fiptool
 ffb774212 build: use new toolchain variables for tools
 cc277de81 build: refactor toolchain detection
 503cf9927 refactor(juno): move plat_def_uuid_config to fiptool
 4d4fec281 feat(fiptool): add ability to build statically
 352366ede refactor(ethos-n): move build flags to ethosn_npu.mk
 aa57ce632 build(tools): avoid unnecessary link
 d4affdce8 Merge "fix(stm32mp1): add void entry in plat_def_toc_entries" into integration
 570a23099 fix(fiptool): move juno plat_fiptool.mk
 8214ecdab fix(stm32mp1): add void entry in plat_def_toc_entries

Signed-off-by: Daniel Golle <daniel@makrotopia.org>
2025-02-13 03:16:40 +00:00

12 lines
319 B
Diff

--- a/tools/fiptool/Makefile
+++ b/tools/fiptool/Makefile
@@ -74,7 +74,7 @@ all: --openssl ${PROJECT}
${PROJECT}: ${OBJECTS} Makefile
$(s)echo " HOSTLD $@"
- $(q)$(host-cc) ${OBJECTS} -o $@ $(LDOPTS)
+ $(q)$(host-cc) ${OBJECTS} -o $@ $(LDOPTS) $(LDFLAGS)
$(s)echo
$(s)echo "Built $@ successfully"
$(s)echo