There is some new changes since 12.5.r2 to 12.5.5, so refresh and update patches. Changes: modified: package/kernel/qca-nss-dp/Makefile modified: package/kernel/qca-nss-dp/patches/0006-nss_dp_main-Use-a-phy-handle-property-to-connect-to-.patch modified: package/kernel/qca-nss-dp/patches/0008-nss-dp-allow-setting-netdev-name-from-DTS.patch deleted: package/kernel/qca-nss-dp/patches/0011-01-edma_v1-rework-hw_reset-logic-to-permit-rmmod-and-in.patch deleted: package/kernel/qca-nss-dp/patches/0011-02-nss_dp_switchdev-correctly-unregister-notifier-on-dp.patch deleted: package/kernel/qca-nss-dp/patches/0011-03-nss_dp_main-swap-dp_exit-function-call.patch deleted: package/kernel/qca-nss-dp/patches/0011-04-nss_dp_main-call-unregister_netdev-first-in-dp_remov.patch deleted: package/kernel/qca-nss-dp/patches/0011-05-nss_dp_main-use-phy_detach-instead-of-disconnect-in-.patch deleted: package/kernel/qca-nss-dp/patches/0011-06-edma_v1-skip-edma_disable_port-in-edma_cleanup-subse.patch Log: 2024-10-16 |4c9f671| [qca-nss-dp] removed the calling of fal_port_autoneg_status_get 2024-10-16 |fb33119| Merge "[qca-nss-dp] Change Debug Level of TX Complete Errors" 2024-10-15 |e197b9d| [qca-nss-dp] Change Debug Level of TX Complete Errors 2024-10-03 |1b7aeb1| Merge remote-tracking branch origin/AU_LINUX_QSDK_GINGER_OPEN_TARGET_ALL.12.5.5.230.918 into HEAD 2024-10-01 |830ac73| Merge "[qca-nss-dp] Enable rmmod support for qca-nss-dp module." 2024-06-05 |aef242d| [qca-nss-dp] Enable rmmod support for qca-nss-dp module. 2024-09-18 |b1bfeb6| Merge "[qca-nss-dp] Move pr_info to pr_debug" 2024-09-12 |54aee26| Merge "[qca-nss-dp] Fix Loopback ring teardown path" 2024-09-10 |21f6567| Merge "[qca-nss-dp] Extend Tx Complete errors to track individual error type" 2024-09-10 |7fee76f| Merge "[qca-nss-dp] Destination VP xmit support" 2024-09-09 |0d4ecfd| [qca-nss-dp] Fix Loopback ring teardown path 2024-08-29 |438ab8e| [qca-nss-dp] Move pr_info to pr_debug 2024-08-29 |3f45e3d| Merge "[qca-nss-dp] Fix EDMA Recovery API to Prevent Multiple RX NAPI Add Calls" 2024-08-23 |7a792b1| [qca-nss-dp] Fix EDMA Recovery API to Prevent Multiple RX NAPI Add Calls 2024-07-08 |1227746| [qca-nss-dp] Add support for DDR extended buffer 2024-08-20 |d45bceb| [qca-nss-dp] Extend Tx Complete errors to track individual error type 2024-06-17 |a8f7155| [qca-nss-dp] Destination VP xmit support 2024-08-21 |a5d189b| Merge "[qca-nss-dp] Support for the PPE-VP Qdisc feature" 2024-08-16 |da97bc7| Merge "[qca-nss-dp] Restrict compilation of a file in DP module" 2024-06-22 |bf90fe9| [qca-nss-dp] Support for the PPE-VP Qdisc feature 2024-02-07 |6ceeb8f| [qca-nss-dp] Enable EDMA driver to allocate from beyond 4GB space. 2024-03-19 |4a7ff28| [qca-nss-dp] Restrict compilation of a file in DP module 2024-07-09 |73bad34| [qca-nss-dp] Check for DS node state before getting ppe queue 2024-05-03 |22cdbd6| [qca-nss-dp] Add PPE-DS Enqueue vp to queue mapping 2024-07-04 |5d6ef18| Merge "[qca-nss-dp] NAPI Budget change for KPI improvement" 2024-07-02 |cd0b543| Merge "[qca-nss-dp] Read fake_mac header indication from rx_desc" 2024-07-01 |160b988| [qca-nss-dp] NAPI Budget change for KPI improvement 2024-05-22 |54c2fd1| [qca-nss-dp]: Fixing SA warnings as part of qca-nss-dp module. 2024-06-22 |602534b| [qca-nss-dp] Read fake_mac header indication from rx_desc 2023-11-24 |10210e2| [qca-nss-dp] EDMA register changes for ipq54xx 2024-05-22 |1af0d03| Merge "[qca-nss-dp]: Change to support PPE-VP path for MLO Assist" 2024-05-15 |2acd9f3| [qca-nss-dp]: Change to support PPE-VP path for MLO Assist 2023-09-27 |1ca59f2| [qca-nss-dp] DP changes for ipq54xx 2024-04-18 |bc60c5a| Merge "[qca-nss-dp] Add support for the XGMAC latency computation" 2024-04-18 |6a67d6d| Merge "[qca-nss-dp] Fix the packets processing in the Rx NAPI" Signed-off-by: Kristian Skramstad <kristian+github@83.no> Link: https://github.com/openwrt/openwrt/pull/17731 Signed-off-by: Robert Marko <robimarko@gmail.com>
42 lines
1.5 KiB
Diff
42 lines
1.5 KiB
Diff
From ba430b1a512dc1972807a1dd5a8d31a78ac572ff Mon Sep 17 00:00:00 2001
|
|
From: Ziyang Huang <hzyitc@outlook.com>
|
|
Date: Mon, 22 Apr 2024 21:49:18 +0800
|
|
Subject: [PATCH] ipq50xx: use corrent scm function to write tcsr
|
|
|
|
QCA leverages its own API function to write to the TCSR register space,
|
|
not available upstream. As such, convert to the upstream qcom SCM IO
|
|
write function.
|
|
|
|
Signed-off-by: Ziyang Huang <hzyitc@outlook.com>
|
|
Signed-off-by: George Moussalem <george.moussalem@outlook.com>
|
|
---
|
|
hal/soc_ops/ipq50xx/nss_ipq50xx.c | 9 ++-------
|
|
1 file changed, 2 insertions(+), 7 deletions(-)
|
|
|
|
--- a/hal/soc_ops/ipq50xx/nss_ipq50xx.c
|
|
+++ b/hal/soc_ops/ipq50xx/nss_ipq50xx.c
|
|
@@ -18,7 +18,7 @@
|
|
|
|
#include <linux/of.h>
|
|
#include <linux/ioport.h>
|
|
-#include <linux/qcom_scm.h>
|
|
+#include <linux/firmware/qcom/qcom_scm.h>
|
|
#include "nss_dp_hal.h"
|
|
|
|
/*
|
|
@@ -78,13 +78,8 @@ static void nss_dp_hal_tcsr_set(void)
|
|
* If TZ is not enabled, we can write to the register directly.
|
|
*/
|
|
if (qcom_scm_is_available()) {
|
|
-#if (LINUX_VERSION_CODE < KERNEL_VERSION(5, 4, 0))
|
|
- err = qcom_scm_tcsr_reg_write((tcsr_base + TCSR_GMAC_AXI_CACHE_OVERRIDE_OFFSET),
|
|
+ err = qcom_scm_io_writel((tcsr_base + TCSR_GMAC_AXI_CACHE_OVERRIDE_OFFSET),
|
|
TCSR_GMAC_AXI_CACHE_OVERRIDE_VALUE);
|
|
-#else
|
|
- err = qti_scm_tcsr_reg_write((tcsr_base + TCSR_GMAC_AXI_CACHE_OVERRIDE_OFFSET),
|
|
- TCSR_GMAC_AXI_CACHE_OVERRIDE_VALUE);
|
|
-#endif
|
|
if (err) {
|
|
pr_err("%s: SCM TCSR write error: %d\n", __func__, err);
|
|
}
|