RTL8261N is used on some Airoha and Realtek devices. Move the driver from Mediatek to generic so it can be used everywhere. Signed-off-by: Andrew LaMarche <andrewjlamarche@gmail.com> Link: https://github.com/openwrt/openwrt/pull/18163 Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
31 lines
984 B
Diff
31 lines
984 B
Diff
From: "haoming.chen" <haoming.chen@siflower.com.cn>
|
|
Date: Thu, 7 Nov 2024 20:18:59 +0800
|
|
Subject: [PATCH 19/20] net: phy: add support for Siflower SF23P1211 &
|
|
SF23P1240
|
|
|
|
Signed-off-by: haoming.chen <haoming.chen@siflower.com.cn>
|
|
---
|
|
drivers/net/phy/Kconfig | 5 +++++
|
|
drivers/net/phy/Makefile | 1 +
|
|
2 files changed, 6 insertions(+)
|
|
|
|
--- a/drivers/net/phy/Kconfig
|
|
+++ b/drivers/net/phy/Kconfig
|
|
@@ -484,3 +484,8 @@ endif # PHYLIB
|
|
config MICREL_KS8995MA
|
|
tristate "Micrel KS8995MA 5-ports 10/100 managed Ethernet switch"
|
|
depends on SPI
|
|
+
|
|
+config SIFLOWER_PHY
|
|
+ tristate "Siflower PHYs"
|
|
+ help
|
|
+ Currently supports the SF1211F, SF1240 gigabit PHY.
|
|
--- a/drivers/net/phy/Makefile
|
|
+++ b/drivers/net/phy/Makefile
|
|
@@ -108,3 +108,4 @@ obj-$(CONFIG_STE10XP) += ste10Xp.o
|
|
obj-$(CONFIG_TERANETICS_PHY) += teranetics.o
|
|
obj-$(CONFIG_VITESSE_PHY) += vitesse.o
|
|
obj-$(CONFIG_XILINX_GMII2RGMII) += xilinx_gmii2rgmii.o
|
|
+obj-$(CONFIG_SIFLOWER_PHY) += siflower.o
|
|
\ No newline at end of file
|