kernel: bump 5.10 to 5.10.120
All patches automatically rebased. Build system: x86_64 Build-tested: ipq806x/R7800, x86/64 Signed-off-by: John Audia <therealgraysky@proton.me> (cherry picked from commit f800f8d6fc4f21ed87454aa657ebbf376dc3b6cf)
This commit is contained in:
parent
0ca9367069
commit
ff889898d2
@ -1,2 +1,2 @@
|
|||||||
LINUX_VERSION-5.10 = .119
|
LINUX_VERSION-5.10 = .120
|
||||||
LINUX_KERNEL_HASH-5.10.119 = 3e353e55a2b7074c905c7c517c6dae83eae440f98a12ffd471dc4df1d5172511
|
LINUX_KERNEL_HASH-5.10.120 = 5b7a756004158ece2f5e41795ba523ec201743a736e34ce41cbe09177f7d0e8b
|
||||||
|
@ -13,8 +13,8 @@
|
|||||||
select SWCONFIG
|
select SWCONFIG
|
||||||
--- a/drivers/net/phy/Makefile
|
--- a/drivers/net/phy/Makefile
|
||||||
+++ b/drivers/net/phy/Makefile
|
+++ b/drivers/net/phy/Makefile
|
||||||
@@ -29,6 +29,7 @@ obj-$(CONFIG_ADM6996_PHY) += adm6996.o
|
@@ -31,6 +31,7 @@ ar8xxx-y += ar8216.o
|
||||||
obj-$(CONFIG_AR8216_PHY) += ar8216.o ar8327.o
|
ar8xxx-y += ar8327.o
|
||||||
obj-$(CONFIG_SWCONFIG_B53) += b53/
|
obj-$(CONFIG_SWCONFIG_B53) += b53/
|
||||||
obj-$(CONFIG_IP17XX_PHY) += ip17xx.o
|
obj-$(CONFIG_IP17XX_PHY) += ip17xx.o
|
||||||
+obj-$(CONFIG_MVSWITCH_PHY) += mvswitch.o
|
+obj-$(CONFIG_MVSWITCH_PHY) += mvswitch.o
|
||||||
|
@ -70,7 +70,7 @@ Signed-off-by: Pablo Neira Ayuso <pablo@netfilter.org>
|
|||||||
nft_trans_table_update(trans) = true;
|
nft_trans_table_update(trans) = true;
|
||||||
list_add_tail(&trans->list, &ctx->net->nft.commit_list);
|
list_add_tail(&trans->list, &ctx->net->nft.commit_list);
|
||||||
return 0;
|
return 0;
|
||||||
@@ -7908,11 +7912,10 @@ static int nf_tables_commit(struct net *
|
@@ -7918,11 +7922,10 @@ static int nf_tables_commit(struct net *
|
||||||
switch (trans->msg_type) {
|
switch (trans->msg_type) {
|
||||||
case NFT_MSG_NEWTABLE:
|
case NFT_MSG_NEWTABLE:
|
||||||
if (nft_trans_table_update(trans)) {
|
if (nft_trans_table_update(trans)) {
|
||||||
@ -86,7 +86,7 @@ Signed-off-by: Pablo Neira Ayuso <pablo@netfilter.org>
|
|||||||
} else {
|
} else {
|
||||||
nft_clear(net, trans->ctx.table);
|
nft_clear(net, trans->ctx.table);
|
||||||
}
|
}
|
||||||
@@ -8125,11 +8128,9 @@ static int __nf_tables_abort(struct net
|
@@ -8135,11 +8138,9 @@ static int __nf_tables_abort(struct net
|
||||||
switch (trans->msg_type) {
|
switch (trans->msg_type) {
|
||||||
case NFT_MSG_NEWTABLE:
|
case NFT_MSG_NEWTABLE:
|
||||||
if (nft_trans_table_update(trans)) {
|
if (nft_trans_table_update(trans)) {
|
||||||
|
@ -92,7 +92,7 @@ Signed-off-by: John Crispin <john@phrozen.org>
|
|||||||
bool
|
bool
|
||||||
--- a/lib/Kconfig
|
--- a/lib/Kconfig
|
||||||
+++ b/lib/Kconfig
|
+++ b/lib/Kconfig
|
||||||
@@ -418,16 +418,16 @@ config BCH_CONST_T
|
@@ -420,16 +420,16 @@ config BCH_CONST_T
|
||||||
# Textsearch support is select'ed if needed
|
# Textsearch support is select'ed if needed
|
||||||
#
|
#
|
||||||
config TEXTSEARCH
|
config TEXTSEARCH
|
||||||
|
@ -11,7 +11,7 @@
|
|||||||
that can be interpreted by the ASN.1 stream decoder and used to
|
that can be interpreted by the ASN.1 stream decoder and used to
|
||||||
--- a/lib/Kconfig
|
--- a/lib/Kconfig
|
||||||
+++ b/lib/Kconfig
|
+++ b/lib/Kconfig
|
||||||
@@ -589,7 +589,7 @@ config LIBFDT
|
@@ -591,7 +591,7 @@ config LIBFDT
|
||||||
bool
|
bool
|
||||||
|
|
||||||
config OID_REGISTRY
|
config OID_REGISTRY
|
||||||
|
@ -4,7 +4,7 @@ from backports.
|
|||||||
|
|
||||||
--- a/lib/crypto/Kconfig
|
--- a/lib/crypto/Kconfig
|
||||||
+++ b/lib/crypto/Kconfig
|
+++ b/lib/crypto/Kconfig
|
||||||
@@ -4,7 +4,7 @@ config CRYPTO_LIB_AES
|
@@ -6,7 +6,7 @@ config CRYPTO_LIB_AES
|
||||||
tristate
|
tristate
|
||||||
|
|
||||||
config CRYPTO_LIB_ARC4
|
config CRYPTO_LIB_ARC4
|
||||||
|
@ -1087,7 +1087,7 @@ Signed-off-by: Alexandros C. Couloumbis <alex@ozo.com>
|
|||||||
#define JFFS2_NODE_ACCURATE 0x2000
|
#define JFFS2_NODE_ACCURATE 0x2000
|
||||||
--- a/lib/Kconfig
|
--- a/lib/Kconfig
|
||||||
+++ b/lib/Kconfig
|
+++ b/lib/Kconfig
|
||||||
@@ -315,6 +315,12 @@ config ZSTD_DECOMPRESS
|
@@ -317,6 +317,12 @@ config ZSTD_DECOMPRESS
|
||||||
|
|
||||||
source "lib/xz/Kconfig"
|
source "lib/xz/Kconfig"
|
||||||
|
|
||||||
|
@ -40,7 +40,7 @@ Signed-off-by: Robert Marko <robert.marko@sartura.hr>
|
|||||||
help
|
help
|
||||||
--- a/drivers/net/phy/Makefile
|
--- a/drivers/net/phy/Makefile
|
||||||
+++ b/drivers/net/phy/Makefile
|
+++ b/drivers/net/phy/Makefile
|
||||||
@@ -86,6 +86,7 @@ obj-$(CONFIG_MICROSEMI_PHY) += mscc/
|
@@ -88,6 +88,7 @@ obj-$(CONFIG_MICROSEMI_PHY) += mscc/
|
||||||
obj-$(CONFIG_NATIONAL_PHY) += national.o
|
obj-$(CONFIG_NATIONAL_PHY) += national.o
|
||||||
obj-$(CONFIG_NXP_TJA11XX_PHY) += nxp-tja11xx.o
|
obj-$(CONFIG_NXP_TJA11XX_PHY) += nxp-tja11xx.o
|
||||||
obj-$(CONFIG_QSEMI_PHY) += qsemi.o
|
obj-$(CONFIG_QSEMI_PHY) += qsemi.o
|
||||||
|
@ -15,7 +15,7 @@
|
|||||||
help
|
help
|
||||||
--- a/drivers/net/phy/Makefile
|
--- a/drivers/net/phy/Makefile
|
||||||
+++ b/drivers/net/phy/Makefile
|
+++ b/drivers/net/phy/Makefile
|
||||||
@@ -87,6 +87,7 @@ obj-$(CONFIG_NATIONAL_PHY) += national.o
|
@@ -89,6 +89,7 @@ obj-$(CONFIG_NATIONAL_PHY) += national.o
|
||||||
obj-$(CONFIG_NXP_TJA11XX_PHY) += nxp-tja11xx.o
|
obj-$(CONFIG_NXP_TJA11XX_PHY) += nxp-tja11xx.o
|
||||||
obj-$(CONFIG_QSEMI_PHY) += qsemi.o
|
obj-$(CONFIG_QSEMI_PHY) += qsemi.o
|
||||||
obj-$(CONFIG_REALTEK_PHY) += realtek.o
|
obj-$(CONFIG_REALTEK_PHY) += realtek.o
|
||||||
|
Loading…
x
Reference in New Issue
Block a user