libpcap: update to 1.10.5
Changes: https://git.tcpdump.org/libpcap/blob/bbcbc9174df3298a854daee2b3e666a4b6e5383a:/CHANGES Signed-off-by: Ivan Pavlov <AuthorReflex@gmail.com> Link: https://github.com/openwrt/openwrt/pull/16401 Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
This commit is contained in:
parent
37cedc7e86
commit
c7671a22dc
@ -8,12 +8,12 @@
|
|||||||
include $(TOPDIR)/rules.mk
|
include $(TOPDIR)/rules.mk
|
||||||
|
|
||||||
PKG_NAME:=libpcap
|
PKG_NAME:=libpcap
|
||||||
PKG_VERSION:=1.10.4
|
PKG_VERSION:=1.10.5
|
||||||
PKG_RELEASE:=1
|
PKG_RELEASE:=1
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
|
||||||
PKG_SOURCE_URL:=https://www.tcpdump.org/release/
|
PKG_SOURCE_URL:=https://www.tcpdump.org/release/
|
||||||
PKG_HASH:=ed19a0383fad72e3ad435fd239d7cd80d64916b87269550159d20e47160ebe5f
|
PKG_HASH:=37ced90a19a302a7f32e458224a00c365c117905c2cd35ac544b6880a81488f0
|
||||||
|
|
||||||
PKG_MAINTAINER:=Felix Fietkau <nbd@nbd.name>
|
PKG_MAINTAINER:=Felix Fietkau <nbd@nbd.name>
|
||||||
PKG_LICENSE:=BSD-3-Clause
|
PKG_LICENSE:=BSD-3-Clause
|
||||||
|
@ -1,10 +1,10 @@
|
|||||||
--- a/CMakeLists.txt
|
--- a/CMakeLists.txt
|
||||||
+++ b/CMakeLists.txt
|
+++ b/CMakeLists.txt
|
||||||
@@ -1325,7 +1325,6 @@ endif()
|
@@ -1441,7 +1441,6 @@ if(ENABLE_REMOTE)
|
||||||
#
|
#
|
||||||
# OpenSSL/libressl.
|
# OpenSSL/libressl.
|
||||||
#
|
#
|
||||||
-find_package(OpenSSL)
|
- find_package(OpenSSL)
|
||||||
if(OPENSSL_FOUND)
|
if(OPENSSL_FOUND)
|
||||||
#
|
#
|
||||||
# We have OpenSSL.
|
# We have OpenSSL.
|
||||||
|
@ -9,7 +9,7 @@ Subject: [PATCH] skip manpages
|
|||||||
|
|
||||||
--- a/CMakeLists.txt
|
--- a/CMakeLists.txt
|
||||||
+++ b/CMakeLists.txt
|
+++ b/CMakeLists.txt
|
||||||
@@ -3325,57 +3325,6 @@ if(NOT MSVC)
|
@@ -3548,57 +3548,6 @@ if(NOT MSVC)
|
||||||
if(MINGW)
|
if(MINGW)
|
||||||
find_program(LINK_EXECUTABLE ln)
|
find_program(LINK_EXECUTABLE ln)
|
||||||
endif(MINGW)
|
endif(MINGW)
|
||||||
|
@ -36,7 +36,7 @@ Signed-off-by: Linus Lüssing <linus.luessing@c0d3.blue>
|
|||||||
|
|
||||||
--- a/Makefile.in
|
--- a/Makefile.in
|
||||||
+++ b/Makefile.in
|
+++ b/Makefile.in
|
||||||
@@ -133,6 +133,8 @@ PUBHDR = \
|
@@ -130,6 +130,8 @@ PUBHDR = \
|
||||||
HDR = $(PUBHDR) \
|
HDR = $(PUBHDR) \
|
||||||
arcnet.h \
|
arcnet.h \
|
||||||
atmuni31.h \
|
atmuni31.h \
|
||||||
@ -220,7 +220,7 @@ Signed-off-by: Linus Lüssing <linus.luessing@c0d3.blue>
|
|||||||
#endif
|
#endif
|
||||||
--- a/gencode.c
|
--- a/gencode.c
|
||||||
+++ b/gencode.c
|
+++ b/gencode.c
|
||||||
@@ -60,6 +60,8 @@
|
@@ -58,6 +58,8 @@
|
||||||
#include "sunatmpos.h"
|
#include "sunatmpos.h"
|
||||||
#include "pflog.h"
|
#include "pflog.h"
|
||||||
#include "ppp.h"
|
#include "ppp.h"
|
||||||
@ -229,7 +229,7 @@ Signed-off-by: Linus Lüssing <linus.luessing@c0d3.blue>
|
|||||||
#include "pcap/sll.h"
|
#include "pcap/sll.h"
|
||||||
#include "pcap/ipnet.h"
|
#include "pcap/ipnet.h"
|
||||||
#include "arcnet.h"
|
#include "arcnet.h"
|
||||||
@@ -9436,6 +9438,168 @@ gen_geneve(compiler_state_t *cstate, bpf
|
@@ -9704,6 +9706,168 @@ gen_geneve(compiler_state_t *cstate, bpf
|
||||||
return b1;
|
return b1;
|
||||||
}
|
}
|
||||||
|
|
||||||
@ -412,7 +412,7 @@ Signed-off-by: Linus Lüssing <linus.luessing@c0d3.blue>
|
|||||||
struct block *gen_atmtype_abbrev(compiler_state_t *, int);
|
struct block *gen_atmtype_abbrev(compiler_state_t *, int);
|
||||||
--- a/grammar.y.in
|
--- a/grammar.y.in
|
||||||
+++ b/grammar.y.in
|
+++ b/grammar.y.in
|
||||||
@@ -375,6 +375,7 @@ DIAG_OFF_BISON_BYACC
|
@@ -383,6 +383,7 @@ DIAG_OFF_BISON_BYACC
|
||||||
%type <i> mtp2type
|
%type <i> mtp2type
|
||||||
%type <blk> mtp3field
|
%type <blk> mtp3field
|
||||||
%type <blk> mtp3fieldvalue mtp3value mtp3listvalue
|
%type <blk> mtp3fieldvalue mtp3value mtp3listvalue
|
||||||
@ -420,7 +420,7 @@ Signed-off-by: Linus Lüssing <linus.luessing@c0d3.blue>
|
|||||||
|
|
||||||
|
|
||||||
%token DST SRC HOST GATEWAY
|
%token DST SRC HOST GATEWAY
|
||||||
@@ -393,7 +394,7 @@ DIAG_OFF_BISON_BYACC
|
@@ -401,7 +402,7 @@ DIAG_OFF_BISON_BYACC
|
||||||
%token LEN
|
%token LEN
|
||||||
%token IPV6 ICMPV6 AH ESP
|
%token IPV6 ICMPV6 AH ESP
|
||||||
%token VLAN MPLS
|
%token VLAN MPLS
|
||||||
@ -429,7 +429,7 @@ Signed-off-by: Linus Lüssing <linus.luessing@c0d3.blue>
|
|||||||
%token ISO ESIS CLNP ISIS L1 L2 IIH LSP SNP CSNP PSNP
|
%token ISO ESIS CLNP ISIS L1 L2 IIH LSP SNP CSNP PSNP
|
||||||
%token STP
|
%token STP
|
||||||
%token IPX
|
%token IPX
|
||||||
@@ -620,11 +621,40 @@ other: pqual TK_BROADCAST { CHECK_PTR_
|
@@ -698,11 +699,40 @@ other: pqual TK_BROADCAST { CHECK_PTR_
|
||||||
| PPPOES { CHECK_PTR_VAL(($$ = gen_pppoes(cstate, 0, 0))); }
|
| PPPOES { CHECK_PTR_VAL(($$ = gen_pppoes(cstate, 0, 0))); }
|
||||||
| GENEVE pnum { CHECK_PTR_VAL(($$ = gen_geneve(cstate, $2, 1))); }
|
| GENEVE pnum { CHECK_PTR_VAL(($$ = gen_geneve(cstate, $2, 1))); }
|
||||||
| GENEVE { CHECK_PTR_VAL(($$ = gen_geneve(cstate, 0, 0))); }
|
| GENEVE { CHECK_PTR_VAL(($$ = gen_geneve(cstate, 0, 0))); }
|
||||||
@ -472,7 +472,7 @@ Signed-off-by: Linus Lüssing <linus.luessing@c0d3.blue>
|
|||||||
| PF_RNR NUM { CHECK_PTR_VAL(($$ = gen_pf_rnr(cstate, $2))); }
|
| PF_RNR NUM { CHECK_PTR_VAL(($$ = gen_pf_rnr(cstate, $2))); }
|
||||||
--- a/nametoaddr.c
|
--- a/nametoaddr.c
|
||||||
+++ b/nametoaddr.c
|
+++ b/nametoaddr.c
|
||||||
@@ -136,8 +136,12 @@
|
@@ -134,8 +134,12 @@
|
||||||
|
|
||||||
#include "diag-control.h"
|
#include "diag-control.h"
|
||||||
|
|
||||||
@ -484,8 +484,8 @@ Signed-off-by: Linus Lüssing <linus.luessing@c0d3.blue>
|
|||||||
+
|
+
|
||||||
#include "nametoaddr.h"
|
#include "nametoaddr.h"
|
||||||
|
|
||||||
#ifdef HAVE_OS_PROTO_H
|
#include "thread-local.h"
|
||||||
@@ -604,6 +608,7 @@ PCAP_API_DEF struct eproto eproto_db[] =
|
@@ -597,6 +601,7 @@ PCAP_API_DEF struct eproto eproto_db[] =
|
||||||
{ "moprc", ETHERTYPE_MOPRC },
|
{ "moprc", ETHERTYPE_MOPRC },
|
||||||
{ "rarp", ETHERTYPE_REVARP },
|
{ "rarp", ETHERTYPE_REVARP },
|
||||||
{ "sca", ETHERTYPE_SCA },
|
{ "sca", ETHERTYPE_SCA },
|
||||||
@ -493,7 +493,7 @@ Signed-off-by: Linus Lüssing <linus.luessing@c0d3.blue>
|
|||||||
{ (char *)0, 0 }
|
{ (char *)0, 0 }
|
||||||
};
|
};
|
||||||
|
|
||||||
@@ -638,6 +643,60 @@ pcap_nametollc(const char *s)
|
@@ -631,6 +636,60 @@ pcap_nametollc(const char *s)
|
||||||
|
|
||||||
while (p->s != 0) {
|
while (p->s != 0) {
|
||||||
if (strcmp(p->s, s) == 0)
|
if (strcmp(p->s, s) == 0)
|
||||||
@ -582,7 +582,7 @@ Signed-off-by: Linus Lüssing <linus.luessing@c0d3.blue>
|
|||||||
Abbreviations for:
|
Abbreviations for:
|
||||||
.in +.5i
|
.in +.5i
|
||||||
.nf
|
.nf
|
||||||
@@ -792,6 +793,36 @@ For example:
|
@@ -795,6 +796,36 @@ For example:
|
||||||
filters IPv4 protocol encapsulated in Geneve with VNI 0xb. This will
|
filters IPv4 protocol encapsulated in Geneve with VNI 0xb. This will
|
||||||
match both IPv4 directly encapsulated in Geneve as well as IPv4 contained
|
match both IPv4 directly encapsulated in Geneve as well as IPv4 contained
|
||||||
inside an Ethernet frame.
|
inside an Ethernet frame.
|
||||||
@ -621,18 +621,18 @@ Signed-off-by: Linus Lüssing <linus.luessing@c0d3.blue>
|
|||||||
\fIProtocol\fP can be a number or one of the names
|
\fIProtocol\fP can be a number or one of the names
|
||||||
--- a/pcap/namedb.h
|
--- a/pcap/namedb.h
|
||||||
+++ b/pcap/namedb.h
|
+++ b/pcap/namedb.h
|
||||||
@@ -70,6 +70,8 @@ PCAP_API int pcap_nametoportrange(const
|
@@ -94,6 +94,8 @@ PCAP_API int pcap_nametoeproto(const cha
|
||||||
PCAP_API int pcap_nametoproto(const char *);
|
|
||||||
PCAP_API int pcap_nametoeproto(const char *);
|
PCAP_AVAILABLE_0_9
|
||||||
PCAP_API int pcap_nametollc(const char *);
|
PCAP_API int pcap_nametollc(const char *);
|
||||||
+PCAP_API int pcap_nametobatadvtype_v14(const char *);
|
+PCAP_API int pcap_nametobatadvtype_v14(const char *);
|
||||||
+PCAP_API int pcap_nametobatadvtype_v15(const char *);
|
+PCAP_API int pcap_nametobatadvtype_v15(const char *);
|
||||||
|
|
||||||
/*
|
/*
|
||||||
* If a protocol is unknown, PROTO_UNDEF is returned.
|
* If a protocol is unknown, PROTO_UNDEF is returned.
|
||||||
* Also, pcap_nametoport() returns the protocol along with the port number.
|
|
||||||
--- a/scanner.l
|
--- a/scanner.l
|
||||||
+++ b/scanner.l
|
+++ b/scanner.l
|
||||||
@@ -347,6 +347,7 @@ mpls return MPLS;
|
@@ -365,6 +365,7 @@ mpls return MPLS;
|
||||||
pppoed return PPPOED;
|
pppoed return PPPOED;
|
||||||
pppoes return PPPOES;
|
pppoes return PPPOES;
|
||||||
geneve return GENEVE;
|
geneve return GENEVE;
|
||||||
|
Loading…
x
Reference in New Issue
Block a user