toolchain: binutils: add support for 2.43
Drop two backported patches, and autorefresh the rest. Release notes: https://lists.gnu.org/archive/html/info-gnu/2024-08/msg00001.html Link: https://github.com/openwrt/openwrt/pull/16175 Signed-off-by: Chuanhong Guo <gch981213@gmail.com>
This commit is contained in:
parent
17f07040e7
commit
9cf6ce5179
@ -29,6 +29,10 @@ choice
|
|||||||
config BINUTILS_USE_VERSION_2_42
|
config BINUTILS_USE_VERSION_2_42
|
||||||
bool "Binutils 2.42"
|
bool "Binutils 2.42"
|
||||||
select BINUTILS_VERSION_2_42
|
select BINUTILS_VERSION_2_42
|
||||||
|
|
||||||
|
config BINUTILS_USE_VERSION_2_43
|
||||||
|
bool "Binutils 2.43"
|
||||||
|
select BINUTILS_VERSION_2_43
|
||||||
endchoice
|
endchoice
|
||||||
|
|
||||||
config EXTRA_BINUTILS_CONFIG_OPTIONS
|
config EXTRA_BINUTILS_CONFIG_OPTIONS
|
||||||
|
@ -18,6 +18,9 @@ config BINUTILS_VERSION_2_42
|
|||||||
default y if !TOOLCHAINOPTS
|
default y if !TOOLCHAINOPTS
|
||||||
bool
|
bool
|
||||||
|
|
||||||
|
config BINUTILS_VERSION_2_43
|
||||||
|
bool
|
||||||
|
|
||||||
config BINUTILS_VERSION
|
config BINUTILS_VERSION
|
||||||
string
|
string
|
||||||
default "2.37" if BINUTILS_VERSION_2_37
|
default "2.37" if BINUTILS_VERSION_2_37
|
||||||
@ -26,3 +29,4 @@ config BINUTILS_VERSION
|
|||||||
default "2.40" if BINUTILS_VERSION_2_40
|
default "2.40" if BINUTILS_VERSION_2_40
|
||||||
default "2.41" if BINUTILS_VERSION_2_41
|
default "2.41" if BINUTILS_VERSION_2_41
|
||||||
default "2.42" if BINUTILS_VERSION_2_42
|
default "2.42" if BINUTILS_VERSION_2_42
|
||||||
|
default "2.43" if BINUTILS_VERSION_2_43
|
||||||
|
@ -40,6 +40,10 @@ ifeq ($(PKG_VERSION),2.42)
|
|||||||
PKG_HASH:=f6e4d41fd5fc778b06b7891457b3620da5ecea1006c6a4a41ae998109f85a800
|
PKG_HASH:=f6e4d41fd5fc778b06b7891457b3620da5ecea1006c6a4a41ae998109f85a800
|
||||||
endif
|
endif
|
||||||
|
|
||||||
|
ifeq ($(PKG_VERSION),2.43)
|
||||||
|
PKG_HASH:=b53606f443ac8f01d1d5fc9c39497f2af322d99e14cea5c0b4b124d630379365
|
||||||
|
endif
|
||||||
|
|
||||||
HOST_BUILD_PARALLEL:=1
|
HOST_BUILD_PARALLEL:=1
|
||||||
|
|
||||||
PATCH_DIR:=./patches/$(PKG_VERSION)
|
PATCH_DIR:=./patches/$(PKG_VERSION)
|
||||||
|
@ -0,0 +1,22 @@
|
|||||||
|
--- a/ld/Makefile.am
|
||||||
|
+++ b/ld/Makefile.am
|
||||||
|
@@ -50,7 +50,7 @@ AM_CFLAGS = $(WARN_CFLAGS) $(ELF_CFLAGS)
|
||||||
|
# We put the scripts in the directory $(scriptdir)/ldscripts.
|
||||||
|
# We can't put the scripts in $(datadir) because the SEARCH_DIR
|
||||||
|
# directives need to be different for native and cross linkers.
|
||||||
|
-scriptdir = $(tooldir)/lib
|
||||||
|
+scriptdir = $(libdir)
|
||||||
|
|
||||||
|
EMUL = @EMUL@
|
||||||
|
EMULATION_OFILES = @EMULATION_OFILES@
|
||||||
|
--- a/ld/Makefile.in
|
||||||
|
+++ b/ld/Makefile.in
|
||||||
|
@@ -583,7 +583,7 @@ AM_CFLAGS = $(WARN_CFLAGS) $(ELF_CFLAGS)
|
||||||
|
# We put the scripts in the directory $(scriptdir)/ldscripts.
|
||||||
|
# We can't put the scripts in $(datadir) because the SEARCH_DIR
|
||||||
|
# directives need to be different for native and cross linkers.
|
||||||
|
-scriptdir = $(tooldir)/lib
|
||||||
|
+scriptdir = $(libdir)
|
||||||
|
BASEDIR = $(srcdir)/..
|
||||||
|
BFDDIR = $(BASEDIR)/bfd
|
||||||
|
INCDIR = $(BASEDIR)/include
|
@ -0,0 +1,18 @@
|
|||||||
|
--- a/bfd/elfxx-mips.c
|
||||||
|
+++ b/bfd/elfxx-mips.c
|
||||||
|
@@ -8161,6 +8161,7 @@ _bfd_mips_elf_create_dynamic_sections (b
|
||||||
|
|
||||||
|
name = SGI_COMPAT (abfd) ? "_DYNAMIC_LINK" : "_DYNAMIC_LINKING";
|
||||||
|
bh = NULL;
|
||||||
|
+ if (0) {
|
||||||
|
if (!(_bfd_generic_link_add_one_symbol
|
||||||
|
(info, abfd, name, BSF_GLOBAL, bfd_abs_section_ptr, 0,
|
||||||
|
NULL, false, get_elf_backend_data (abfd)->collect, &bh)))
|
||||||
|
@@ -8173,6 +8174,7 @@ _bfd_mips_elf_create_dynamic_sections (b
|
||||||
|
|
||||||
|
if (! bfd_elf_link_record_dynamic_symbol (info, h))
|
||||||
|
return false;
|
||||||
|
+ }
|
||||||
|
|
||||||
|
if (! mips_elf_hash_table (info)->use_rld_obj_head)
|
||||||
|
{
|
@ -0,0 +1,48 @@
|
|||||||
|
--- a/bfd/config.bfd
|
||||||
|
+++ b/bfd/config.bfd
|
||||||
|
@@ -962,8 +962,8 @@ case "${targ}" in
|
||||||
|
want64=true
|
||||||
|
;;
|
||||||
|
mips64*el-*-linux*)
|
||||||
|
- targ_defvec=mips_elf32_ntrad_le_vec
|
||||||
|
- targ_selvecs="mips_elf32_ntrad_be_vec mips_elf32_trad_le_vec mips_elf32_trad_be_vec mips_elf64_trad_le_vec mips_elf64_trad_be_vec"
|
||||||
|
+ targ_defvec=mips_elf64_trad_le_vec
|
||||||
|
+ targ_selvecs="mips_elf32_ntrad_le_vec mips_elf32_ntrad_be_vec mips_elf32_trad_le_vec mips_elf32_trad_be_vec mips_elf64_trad_be_vec"
|
||||||
|
;;
|
||||||
|
mips64*-*-linux*-gnuabi64)
|
||||||
|
targ_defvec=mips_elf64_trad_be_vec
|
||||||
|
@@ -971,8 +971,8 @@ case "${targ}" in
|
||||||
|
want64=true
|
||||||
|
;;
|
||||||
|
mips64*-*-linux*)
|
||||||
|
- targ_defvec=mips_elf32_ntrad_be_vec
|
||||||
|
- targ_selvecs="mips_elf32_ntrad_le_vec mips_elf32_trad_be_vec mips_elf32_trad_le_vec mips_elf64_trad_be_vec mips_elf64_trad_le_vec"
|
||||||
|
+ targ_defvec=mips_elf64_trad_be_vec
|
||||||
|
+ targ_selvecs="mips_elf32_ntrad_be_vec mips_elf32_ntrad_le_vec mips_elf32_trad_be_vec mips_elf32_trad_le_vec mips_elf64_trad_le_vec"
|
||||||
|
;;
|
||||||
|
mips*el-*-linux*)
|
||||||
|
targ_defvec=mips_elf32_trad_le_vec
|
||||||
|
--- a/ld/configure.tgt
|
||||||
|
+++ b/ld/configure.tgt
|
||||||
|
@@ -597,8 +597,8 @@ mips64*el-*-linux-gnuabi64)
|
||||||
|
targ_extra_emuls="elf64btsmip elf32ltsmipn32 elf32btsmipn32 elf32ltsmip elf32btsmip"
|
||||||
|
targ_extra_libpath=$targ_extra_emuls
|
||||||
|
;;
|
||||||
|
-mips64*el-*-linux-*) targ_emul=elf32ltsmipn32
|
||||||
|
- targ_extra_emuls="elf32btsmipn32 elf32ltsmip elf32btsmip elf64ltsmip elf64btsmip"
|
||||||
|
+mips64*el-*-linux-*) targ_emul=elf64ltsmip
|
||||||
|
+ targ_extra_emuls="elf32btsmipn32 elf32ltsmipn32 elf32ltsmip elf32btsmip elf64btsmip"
|
||||||
|
targ_extra_libpath=$targ_extra_emuls
|
||||||
|
;;
|
||||||
|
mips64*-*-linux-gnuabi64)
|
||||||
|
@@ -606,8 +606,8 @@ mips64*-*-linux-gnuabi64)
|
||||||
|
targ_extra_emuls="elf64ltsmip elf32btsmipn32 elf32ltsmipn32 elf32btsmip elf32ltsmip"
|
||||||
|
targ_extra_libpath=$targ_extra_emuls
|
||||||
|
;;
|
||||||
|
-mips64*-*-linux-*) targ_emul=elf32btsmipn32
|
||||||
|
- targ_extra_emuls="elf32ltsmipn32 elf32btsmip elf32ltsmip elf64btsmip elf64ltsmip"
|
||||||
|
+mips64*-*-linux-*) targ_emul=elf64btsmip
|
||||||
|
+ targ_extra_emuls="elf32btsmipn32 elf32ltsmipn32 elf32btsmip elf32ltsmip elf64ltsmip"
|
||||||
|
targ_extra_libpath=$targ_extra_emuls
|
||||||
|
;;
|
||||||
|
mips*el-*-linux-*) targ_emul=elf32ltsmip
|
Loading…
x
Reference in New Issue
Block a user