tools/ccache: update to 4.6.2
Release notes: https://ccache.dev/releasenotes.html#_ccache_4_6_2 Signed-off-by: Nick Hainke <vincent@systemli.org> (cherry picked from commit ac61cf596cc4cdfb93981361b093c1d97e4a1b96)
This commit is contained in:
parent
eeff8b3be1
commit
80653f0c07
@ -8,11 +8,11 @@ include $(TOPDIR)/rules.mk
|
|||||||
include $(INCLUDE_DIR)/target.mk
|
include $(INCLUDE_DIR)/target.mk
|
||||||
|
|
||||||
PKG_NAME:=ccache
|
PKG_NAME:=ccache
|
||||||
PKG_VERSION:=4.6.1
|
PKG_VERSION:=4.6.2
|
||||||
|
|
||||||
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
|
||||||
PKG_SOURCE_URL:=https://github.com/ccache/ccache/releases/download/v$(PKG_VERSION)
|
PKG_SOURCE_URL:=https://github.com/ccache/ccache/releases/download/v$(PKG_VERSION)
|
||||||
PKG_HASH:=e5d47bd3cbb504ada864124690e7c0d28ecb1f9aeac22a9976025aed9633f3d1
|
PKG_HASH:=789a2435d7fde2eaef5ec7b3ecf2366e546f764253e9999fdf008d2dd7f3b10c
|
||||||
|
|
||||||
include $(INCLUDE_DIR)/host-build.mk
|
include $(INCLUDE_DIR)/host-build.mk
|
||||||
include $(INCLUDE_DIR)/cmake.mk
|
include $(INCLUDE_DIR)/cmake.mk
|
||||||
|
@ -1,6 +1,6 @@
|
|||||||
--- a/src/ccache.cpp
|
--- a/src/ccache.cpp
|
||||||
+++ b/src/ccache.cpp
|
+++ b/src/ccache.cpp
|
||||||
@@ -1754,6 +1754,7 @@ calculate_result_and_manifest_key(Contex
|
@@ -1750,6 +1750,7 @@ calculate_result_and_manifest_key(Contex
|
||||||
"CPLUS_INCLUDE_PATH",
|
"CPLUS_INCLUDE_PATH",
|
||||||
"OBJC_INCLUDE_PATH",
|
"OBJC_INCLUDE_PATH",
|
||||||
"OBJCPLUS_INCLUDE_PATH", // clang
|
"OBJCPLUS_INCLUDE_PATH", // clang
|
||||||
|
@ -22,9 +22,9 @@ Subject: [PATCH] fix: Fix build with musl when using GCC 12 (#1145)
|
|||||||
#include <limits>
|
#include <limits>
|
||||||
--- a/src/core/Statistics.hpp
|
--- a/src/core/Statistics.hpp
|
||||||
+++ b/src/core/Statistics.hpp
|
+++ b/src/core/Statistics.hpp
|
||||||
@@ -21,6 +21,7 @@
|
@@ -22,6 +22,7 @@
|
||||||
#include <core/StatisticsCounters.hpp>
|
|
||||||
|
|
||||||
|
#include <cstdint>
|
||||||
#include <string>
|
#include <string>
|
||||||
+#include <ctime>
|
+#include <ctime>
|
||||||
#include <unordered_map>
|
#include <unordered_map>
|
||||||
|
Loading…
x
Reference in New Issue
Block a user