ramips: gpio: remove header "gpio.h"
There are no source files using it. Signed-off-by: Shiji Yang <yangshiji66@qq.com>
This commit is contained in:
parent
24459dc108
commit
256f1648e7
@ -7,41 +7,12 @@ RT2880, RT305x, rt3352, rt3662, rt3883, rt5350 and mt7620 work.
|
|||||||
|
|
||||||
Signed-off-by: John Crispin <blogic@openwrt.org>
|
Signed-off-by: John Crispin <blogic@openwrt.org>
|
||||||
---
|
---
|
||||||
arch/mips/include/asm/mach-ralink/gpio.h | 24 ++
|
|
||||||
drivers/gpio/Kconfig | 6 +
|
drivers/gpio/Kconfig | 6 +
|
||||||
drivers/gpio/Makefile | 1 +
|
drivers/gpio/Makefile | 1 +
|
||||||
drivers/gpio/gpio-ralink.c | 336 +++++++++++++++++++++++
|
drivers/gpio/gpio-ralink.c | 336 +++++++++++++++++++++++++++++++++++++
|
||||||
4 files changed, 367 insertions(+)
|
3 files changed, 343 insertions(+)
|
||||||
create mode 100644 arch/mips/include/asm/mach-ralink/gpio.h
|
|
||||||
create mode 100644 drivers/gpio/gpio-ralink.c
|
create mode 100644 drivers/gpio/gpio-ralink.c
|
||||||
|
|
||||||
--- /dev/null
|
|
||||||
+++ b/arch/mips/include/asm/mach-ralink/gpio.h
|
|
||||||
@@ -0,0 +1,24 @@
|
|
||||||
+/*
|
|
||||||
+ * Ralink SoC GPIO API support
|
|
||||||
+ *
|
|
||||||
+ * Copyright (C) 2008-2009 Gabor Juhos <juhosg@openwrt.org>
|
|
||||||
+ * Copyright (C) 2008 Imre Kaloz <kaloz@openwrt.org>
|
|
||||||
+ *
|
|
||||||
+ * This program is free software; you can redistribute it and/or modify it
|
|
||||||
+ * under the terms of the GNU General Public License version 2 as published
|
|
||||||
+ * by the Free Software Foundation.
|
|
||||||
+ *
|
|
||||||
+ */
|
|
||||||
+
|
|
||||||
+#ifndef __ASM_MACH_RALINK_GPIO_H
|
|
||||||
+#define __ASM_MACH_RALINK_GPIO_H
|
|
||||||
+
|
|
||||||
+#define ARCH_NR_GPIOS 128
|
|
||||||
+#include <asm-generic/gpio.h>
|
|
||||||
+
|
|
||||||
+#define gpio_get_value __gpio_get_value
|
|
||||||
+#define gpio_set_value __gpio_set_value
|
|
||||||
+#define gpio_cansleep __gpio_cansleep
|
|
||||||
+#define gpio_to_irq __gpio_to_irq
|
|
||||||
+
|
|
||||||
+#endif /* __ASM_MACH_RALINK_GPIO_H */
|
|
||||||
--- a/drivers/gpio/Kconfig
|
--- a/drivers/gpio/Kconfig
|
||||||
+++ b/drivers/gpio/Kconfig
|
+++ b/drivers/gpio/Kconfig
|
||||||
@@ -594,6 +594,12 @@ config GPIO_SNPS_CREG
|
@@ -594,6 +594,12 @@ config GPIO_SNPS_CREG
|
||||||
|
Loading…
x
Reference in New Issue
Block a user